REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Automotive Chat > REVscene Nation: Beyond The GVRD > Island Automotive Chat

Island Automotive Chat Victoria to Port Hardy and everything in between
For all your island car related talk.

Reply
 
Thread Tools
Old 09-14-2009, 05:09 PM   #1
14 dolla balla aint got nothing on me!
 
IslandMx3's Avatar
 
Join Date: May 2005
Location: Victoria B.C
Posts: 608
Thanked 0 Times in 0 Posts
Unhappy Idle Problem... help

Ok guys, im stumped on what this could be. I have a 92 mx3 V6. Lately, when im at a stop light and in neutral, my idle will slowly creep down and down until the engine almost stalls. It will idle just above 0 resulting in the car shaking. The idle will go up once i throw up into first and is fine driving, but will slowly drop whenever i am stopped. Could this be a o2 sensor problem?
Thanks in advance for your help!
Advertisement
__________________
92 Mazda MX3

Quote:
If its got tits or tires, its got problems.
IslandMx3 is offline   Reply With Quote
Old 09-14-2009, 05:15 PM   #2
Island Mod
 
projectcivic's Avatar
 
Join Date: Jan 2002
Location: Victoria
Posts: 6,179
Thanked 1 Time in 1 Post
Doubt o2 sensor issue, sounds more like an idle air control valve problem. But I am not familer with mx3's too much.
__________________
1993 Civic Si - b18c1
projectcivic is offline   Reply With Quote
Old 09-27-2009, 08:49 AM   #3
Proud to be called a RS Regular!
 
Gyuji's Avatar
 
Join Date: Jul 2006
Location: Victoria, BC
Posts: 114
Thanked 2 Times in 1 Post
Sounds like idle air control valve. Find it, remove it, clean it out. Less likely, but also double check engine ground. I had odd idle problems with my sr20 and it went away when i regrounded the block.
Gyuji is offline   Reply With Quote
Old 09-27-2009, 11:26 AM   #4
14 dolla balla aint got nothing on me!
 
IslandMx3's Avatar
 
Join Date: May 2005
Location: Victoria B.C
Posts: 608
Thanked 0 Times in 0 Posts
thanks man, ill look at both those things, see if i can fix it. cheers
__________________
92 Mazda MX3

Quote:
If its got tits or tires, its got problems.
IslandMx3 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net