REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Technical Discussion > Manufacturer Tech Forums > Toyota / Lexus Tech Resources

Toyota / Lexus Tech Resources All Toyota & Lexus Tech info
THIS ADSPACE OPEN FOR ADVERTISEMENT

Reply
 
Thread Tools
Old 01-17-2010, 04:12 PM   #1
c32
My dinner reheated before my turbo spooled
 
Join Date: Nov 2005
Location: Vancouver
Posts: 1,763
Thanked 18 Times in 7 Posts
problem with steering

hey guys i got an is300 not to long ago. there has always been this little problem with the steering but i actualy like it.. so sometimes the steering wheel doesnt turn all the way back straight whilte im doing some turns, it would go back to the straight position most of the time, sometimes it just stops at a quarter of a turn(a quarter of a full circle) and jus stay there so i would have move the steering wheel back, steering would also feel very loose but i like it loose, less effort to turn the wheel not sure if its suposed to be lose... i looked in the steering fluid resevoir befor and its pretty dark, was suposed to change the fluid but never did.
so the bigger issue i have now is that it would squeek while im turning the wheel and only when the wheel is being turned, i would get this awful squeek kinda like nails on chalk board but more automotive sounding. i remember it would squeek when i turn the wheel in park just warming up the car but wouldnt make the noise after i warmed up car and left the driveway, but that is only when i coldstart up the car in the morning, never when im driving. also the springs or whatever is makin squeeking noises when i gas/brake... it never make the noise this bad.

car is 2001 is300, is something wrong with the steering rack?
Advertisement
c32 is offline   Reply With Quote
Old 01-17-2010, 04:16 PM   #2
2x Variable Nockenwellen Steuerung
 
Join Date: Oct 2002
Location: N49.2 W122.1
Posts: 6,176
Thanked 1,174 Times in 704 Posts
Could be a multitude of things.. best take it to a shop to get it looked at if you don't have the shop manual.. but I would say it is one of the bearings on the steering wheel column.
godwin is offline   Reply With Quote
Old 01-17-2010, 11:23 PM   #3
I STILL don't get it
 
Hyper_night's Avatar
 
Join Date: May 2004
Location: vancouver
Posts: 457
Thanked 0 Times in 0 Posts
by the sounds of it, sounds it could be the power steering pump, pressure switch or something else. if you bought the car not too long ago, any warranty?
Hyper_night is offline   Reply With Quote
Old 01-17-2010, 11:25 PM   #4
c32
My dinner reheated before my turbo spooled
 
Join Date: Nov 2005
Location: Vancouver
Posts: 1,763
Thanked 18 Times in 7 Posts
no warrenty on it
c32 is offline   Reply With Quote
Old 11-03-2010, 09:50 PM   #5
NOOB, Not Quite a Regular!
 
keyboardcomando's Avatar
 
Join Date: Nov 2010
Location: Sidney
Posts: 32
Thanked 2 Times in 2 Posts
could be a rack seal or the pump?
keyboardcomando is offline   Reply With Quote
Old 03-09-2011, 07:11 PM   #6
14 dolla balla aint got nothing on me!
 
Join Date: May 2007
Location: Vancouver
Posts: 671
Thanked 1,120 Times in 280 Posts
i dont want to disrespect your knowledge of cars but could that squeaking possibly be a worn out fan belt? and the wheel not turning back all the way could just be your caster or it actually might be related to the belt, get it changed... im sure it cant be that much
duy- is offline   Reply With Quote
Old 03-09-2011, 07:55 PM   #7
RS.net, helping ugly ppl have sex since 2001
 
shenmecar's Avatar
 
Join Date: Sep 2008
Location: Vancouver
Posts: 8,858
Thanked 2,420 Times in 669 Posts
thanks you bumped an old thread.
__________________
2014 Honda Civic Si
shenmecar is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net