REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Technical Discussion > Maintenance, Engine & Driveline Tech

Maintenance, Engine & Driveline Tech This forum is brought to you by The Speed Syndicate (TSS) in Burnaby.
Discussion of maintaining your engine, transmission, differentails, rear ends, and mods associated with "driveline" parts..

Reply
 
Thread Tools
Old 09-07-2010, 05:20 PM   #1
NEWBIE ACCOUNT!
 
handyandy21's Avatar
 
Join Date: Oct 2007
Location: Penticton
Posts: 17
Thanked 0 Times in 0 Posts
cars revs go crazy then drops and car stalls while driving?

hey i got this honda with a b16 swap and i was driving it the other day goin bout 50km/h and all of the sudden my tach goes crazy and drops and the car stalls. no engine check light has come on tho. then the car starts back up fine what could this be? any possible things to look for?
Advertisement
handyandy21 is offline   Reply With Quote
Old 09-08-2010, 05:47 PM   #2
Captain Happy Bubble is my Homeboy
 
YK86's Avatar
 
Join Date: Jul 2002
Location: 604
Posts: 333
Thanked 8 Times in 8 Posts
Usually, when the tach starts going crazy and the car dies, it's the ignitor inside the distributor. Some times, it starts up right away or after sitting for a bit but either way, it's usually on it's last legs.
__________________
86 Accord EX-i, 90 Accord EX-R, 97 1.6EL, 99 Mustang GT convert.
YK86 is offline   Reply With Quote
Old 09-09-2010, 12:07 AM   #3
My dinner reheated before my turbo spooled
 
lexluthor09's Avatar
 
Join Date: Nov 2003
Location: Vancouver
Posts: 1,721
Thanked 80 Times in 33 Posts
2nd the distributor/ignition module being the main culprit but it's inside the dizzy.

you can change the part individually if you wanted to.
lexluthor09 is offline   Reply With Quote
Old 09-09-2010, 12:07 AM   #4
My dinner reheated before my turbo spooled
 
lexluthor09's Avatar
 
Join Date: Nov 2003
Location: Vancouver
Posts: 1,721
Thanked 80 Times in 33 Posts
other possible cause is check the ground by the thermostat as that will cause the same problem you stated
lexluthor09 is offline   Reply With Quote
Old 09-09-2010, 10:36 AM   #5
NEWBIE ACCOUNT!
 
handyandy21's Avatar
 
Join Date: Oct 2007
Location: Penticton
Posts: 17
Thanked 0 Times in 0 Posts
ok thanks for the info i replaced the ignitor last year this time that was a easy thing to fix. but ill look into that and the thermostat.
handyandy21 is offline   Reply With Quote
Old 09-09-2010, 10:38 AM   #6
WOAH! i think Vtec just kicked in!
 
FishTaco's Avatar
 
Join Date: Nov 2004
Location: Bangkok
Posts: 1,689
Thanked 1,099 Times in 168 Posts
this happened to me with my jdm crx sir with a b16.. ignition and alternator both died
__________________
★★☆★★LUST★★☆★★
FishTaco is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net