REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Technical Discussion > Maintenance, Engine & Driveline Tech

Maintenance, Engine & Driveline Tech This forum is brought to you by The Speed Syndicate (TSS) in Burnaby.
Discussion of maintaining your engine, transmission, differentails, rear ends, and mods associated with "driveline" parts..

Reply
 
Thread Tools
Old 10-16-2011, 09:36 PM   #1
NEWBIE ACCOUNT!
 
Equilibrity's Avatar
 
Join Date: Nov 2010
Location: new west
Posts: 21
Thanked 3 Times in 1 Post
NEED HELP with my RB20DET ASAP

i got a skyline with blown head gasket, car was parked for few weeks and i decided to swap whole engine.

i got the same rb20det engine, the guy said he rebuilt it recently.

After a swap cur runs but it takes like 10-20 seconds to start it and it has no power to go and running rich. Waaay too rich.
Compression is fine also there are no vacuum leaks.

i don't know if ECU was flashed before or not but injectors were stock on previous engine so i don't think it was tuned..
I need someone who can check all vacuum lines again and help me to troubleshoot/fix the problem.
Advertisement
Equilibrity is offline   Reply With Quote
Old 10-17-2011, 10:58 AM   #2
I contribute to threads in the offtopic forum
 
Join Date: Oct 2009
Location: richmond
Posts: 2,838
Thanked 1,490 Times in 570 Posts
20 years experience Skyline mechanic in house. Give us a ring.
__________________
Rise Auto Salon

11938 95a Ave Delta
I can be reached VIA text @ 778-232-1465

Oil change special $70 5 liters synthetic oil including OEM filter Fender rolling from $45 per fender
Car Audio:
Focal, Morel, Genesis, Clarion, Scosche, Escort, Compustar, GReddy, Blitz, Tomei, Motul, Endless, Defi, Cusco, Nismo + More


We specialize in:
Custom Car Audio
Race/4x4 Fabrication
Forced Induction
Engine Swaps
General Maintenance
Phil@rise is offline   Reply With Quote
Old 10-21-2011, 02:42 PM   #3
RS Lurker, I don't post!
 
Join Date: Oct 2011
Location: Shawnigan Lake
Posts: 3
Thanked 0 Times in 0 Posts
sounds like you may have a bad engine temp sensor Nissan ECU's can be temperamental if they don't see a engine temp that makes sense I don't recall what the right resistance reading should be at 15C but I'll bet it's a bit off and just running off warm up and cold temp fueling tables
hunt_x is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net