REVscene Automotive Forum

REVscene Automotive Forum (https://www.revscene.net/forums/)
-   Nissan / Infiniti Tech Resources (https://www.revscene.net/forums/nissan-infiniti-tech-resources_312/)
-   -   Wiper motor runs, but wipers wont move (wtf) (https://www.revscene.net/forums/668974-wiper-motor-runs-but-wipers-wont-move-wtf.html)

Qmx323 06-02-2012 11:57 PM

Wiper motor runs, but wipers wont move (wtf)
 
Long story short, was on the way home night market with the GF...

Half way home the wipers get stuck at highest position.I pull over and restart the car, turn wipers on...nothing.

I get outta the car, I can hear the motor working; but the wipers just wont "connect" with the motor. So yeah, had to drive for awhile without wipers. :okay: Hoping for anyone with a similar experience to shine some light on this.

Car is a '99 infiniti G20...

Update:

Quote:

Originally Posted by Prolowtone (Post 7936967)
I had the arm from the motor pop off on my car once. the hole for the pivot was all stretched and just popped off, But my car is also from 85 so wear is expected to show up sometime


got the car in the garage, popped a few covers off.

ding ding... exactly what happened. Wiper arm from the motor popped out and no longer moved the wiper pivots.

new bushing time.

godwin 06-03-2012 12:27 AM

You might have stripped the gear.. take the assembly apart and replaced any parts that have metal shavings... I guess you don't lubricate moving parts in your car often?

chris_89T 06-03-2012 09:43 PM

You likely stripped the pivot arms. Not sure if they come seperately or not but you will likely be replacing the entire linkage.

This is why you do not put your wipers on when your wipers are frozen to your windshield. I swear in the winter we replace the linkage on cars once a day.

Eventually they will wear out when the car gets old. Not really something you can lubricate..its just a wear and tear item.

Qmx323 06-03-2012 10:42 PM

Ah, most likely the pivot or something like that. The wipers are still synchronized, so I guess it can't be that bad.

Time to put on some gloves and get wrenchin'

Prolowtone 06-04-2012 02:03 AM

I had the arm from the motor pop off on my car once. the hole for the pivot was all stretched and just popped off, But my car is also from 85 so wear is expected to show up sometime :(

Qmx323 06-05-2012 04:31 PM

Quote:

Originally Posted by godwin (Post 7936069)
You might have stripped the gear.. take the assembly apart and replaced any parts that have metal shavings... I guess you don't lubricate moving parts in your car often?

had the car for less than 2 weeks, hard to predict this would happen :ahwow:


All times are GMT -8. The time now is 09:21 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net