REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Technical Discussion > Manufacturer Tech Forums > Honda / Acura Tech Resources

Honda / Acura Tech Resources All honda & Acura Tech info
THIS ADSPACE OPEN FOR ADVERTISEMENT

Reply
 
Thread Tools
Old 04-21-2017, 11:40 AM   #1
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
Accord dies randomly.

hey guys,

I have a 2007 Accord, 4 cylinder automatic and it turns odd randomly.

It first happened yesterday, I was stopped in a right turn lane and noticed the car died. I put it into park, turned off the car and started it again no problem.
Exact same thing happened today.

anyone know what could cause this?

tia
Advertisement
heisenberg is offline   Reply With Quote
Old 04-21-2017, 11:47 AM   #2
OMGWTFBBQ is a common word I say everyday
 
Join Date: Apr 2006
Location: Tres Ciudades
Posts: 5,406
Thanked 3,679 Times in 1,522 Posts
did it just abruptly die?
or did it struggle to maintain idle rpm then die?

also, any recent tune-up/work done to it?
__________________
"There's a lot of dead people who had the right of way."
"Never argue with stupid people, they will drag you down to their level and beat you with experience."
"I have a lot of beliefs, and I live by none of them. They're just my beliefs, they make me feel good about who I am. But if they get in the way of a thing I want, like I wanna jack off or something, I just do that."
6o4__boi is offline   Reply With Quote
Old 04-21-2017, 03:52 PM   #3
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
yeah, stopped at a light then died out. didn't struggle to idle, just died.

replaced starter, but apparently this happened before replacing the starter. oil change about 1000km ago lol.
it's missing the under carriage under the front bumper lol

any other questions I can answer to help diagnose this?

edit : it would stay at idle at the light, then die
heisenberg is offline   Reply With Quote
Old 04-21-2017, 08:41 PM   #4
Need to Shave n Shower, but I CANT STOP POSTING ON RS
 
Join Date: Oct 2007
Location: Vancouver BC
Posts: 19,072
Thanked 7,231 Times in 3,034 Posts
check your battery terminal
my RSX was doing that...the bolt on the negative terminal was loose.
__________________
My BST Feedback
twitchyzero is online now   Reply With Quote
Old 04-21-2017, 10:05 PM   #5
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
its currently idling at less than 1000rpm, and i just went to turn it on
threw it into reverse, waited like 10 seconds and it died.

oh btw, my CEL is on, and its for engine is too rich / too lean.. can this be the cause?
heisenberg is offline   Reply With Quote
Old 04-21-2017, 10:13 PM   #6
Head of HR....have a seat on that couch
 
fliptuner's Avatar
 
Join Date: Jan 2003
Location: Coquitlam
Posts: 21,056
Thanked 14,296 Times in 3,932 Posts
What's the code?
__________________
feedback

Originally posted by v.b.
can we stop, my pussy hurts...
Originally posted by asian_XL
fliptuner, I am gonna grab ur dick and pee in your face, then rub shit all over my face...:lol
Originally posted by Fei-Ji
haha i can taste the cum in my mouth
Originally posted by FastAnna
when I was 13 I wanted to be a video hoe so bad


RSUV #7
fliptuner is offline   Reply With Quote
Old 04-21-2017, 10:25 PM   #7
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
p0171 and p0172.

im thinking, the o2 sensor is off, and the car isnt getting enough fuel when it idles.
which causes it to "stall" and turn off?
heisenberg is offline   Reply With Quote
Old 04-21-2017, 10:51 PM   #8
I contribute to threads in the offtopic forum
 
Bonka's Avatar
 
Join Date: Dec 2001
Location: Vancouver
Posts: 2,789
Thanked 689 Times in 296 Posts
Check for vacuum line leaks. EVAP, air filter and box, PCV, intake manifold, throttle body, brake booster.
__________________
SHIFT_

"Harvey Belafonte ain't black. He's just a good looking white guy dipped in caramel. " - Archie Bunker
Bonka is offline   Reply With Quote
Old 04-22-2017, 08:48 AM   #9
NOOB, Not Quite a Regular!
 
Join Date: Mar 2011
Location: Richmond
Posts: 44
Thanked 2 Times in 2 Posts
check the Accelerator Pedal Sensor... Very common problem on those years 2.4L or 3.2L engine.

Usually driving like normal. When you slow down the car or wait at stop sign, the idle will suddenly drop and die.
vwaudi34 is offline   Reply With Quote
Old 04-22-2017, 11:09 PM   #10
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
fixed the o2 sensor and it seemed to do the trick. thanks for all the suggestions!
heisenberg is offline   Reply With Quote
Old 04-23-2017, 04:48 PM   #11
14 dolla balla aint got nothing on me!
 
cunninglinguist's Avatar
 
Join Date: Sep 2003
Location: Vancouver
Posts: 620
Thanked 282 Times in 97 Posts
That's really weird. I never heard of an O2 sensor shutting off an engine before.
cunninglinguist is offline   Reply With Quote
Old 04-23-2017, 09:44 PM   #12
RS controls my life!
 
Puck Luck's Avatar
 
Join Date: Apr 2004
Location: lower mainland
Posts: 750
Thanked 93 Times in 78 Posts
Quote:
Originally Posted by cunninglinguist View Post
That's really weird. I never heard of an O2 sensor shutting off an engine before.
I was actually thinking the same thing
__________________
Don't open your hood to strangers........ N 'ouvrez pas votre capot des inconnus
Puck Luck is offline   Reply With Quote
Old 04-23-2017, 11:46 PM   #13
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
think what was going on was the gas to air ratio was off, and it caused the engine to suffocate pretty much.
heisenberg is offline   Reply With Quote
Old 04-24-2017, 09:35 PM   #14
シルビヤ
 
Peturbo's Avatar
 
Join Date: Nov 2004
Location: East Vancouver
Posts: 2,569
Thanked 921 Times in 231 Posts
Don't see how a bad air/fuel sensor can cause stalling. Car runs without using that sensor when in open loop mode until it reaches operating tempature. May just be luck right now of it not stalling anymore at this time.
When the car just died, did your gauge cluster shut off as well as if the key wasn't even in the ignition? or did all your gauges stay lit.
My guess is a loose/worn ignition backhalf. Try wiggling your car keys while the car is running and see if it causes the engine to shut off.
__________________
RIP Jnstyles


Rides
1994 Pearl white S14 Silvia K's
1990 R32 Skyline GTS-T Type-M (Sold)
2008 Civic SI (daily)

My Feedback (30-0-0)
Peturbo is offline   Reply With Quote
Old 04-25-2017, 09:48 AM   #15
Where's my RS Christmas Lobster?!
 
heisenberg's Avatar
 
Join Date: Aug 2012
Location: Vancouver
Posts: 832
Thanked 880 Times in 156 Posts
when it would die, it would go into key position 2 as if i didnt crank the engine to start, but the battery light would come on. all the gauges would pretty much drop tho
heisenberg is offline   Reply With Quote
Old 04-25-2017, 08:12 PM   #16
シルビヤ
 
Peturbo's Avatar
 
Join Date: Nov 2004
Location: East Vancouver
Posts: 2,569
Thanked 921 Times in 231 Posts
Sounds like an ignition back half to me. If it starts happening again, try the little test I mentioned or very slowly turn the key in the ignition. If it hops into position 2 physically but acts as if its in position 1, thats definitely the issue.
__________________
RIP Jnstyles


Rides
1994 Pearl white S14 Silvia K's
1990 R32 Skyline GTS-T Type-M (Sold)
2008 Civic SI (daily)

My Feedback (30-0-0)
Peturbo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 06:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net