REVscene - Vancouver Automotive Forum


Welcome to the REVscene Automotive Forum forums.

Registration is Free!You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today! The banners on the left side and below do not show for registered users!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   REVscene Automotive Forum > Technical Discussion > Maintenance, Engine & Driveline Tech

Maintenance, Engine & Driveline Tech This forum is brought to you by The Speed Syndicate (TSS) in Burnaby.
Discussion of maintaining your engine, transmission, differentails, rear ends, and mods associated with "driveline" parts..

Reply
 
Thread Tools
Old 04-05-2012, 01:07 AM   #1
Proud to be called a RS Regular!
 
hondak20's Avatar
 
Join Date: Feb 2011
Location: Vancouver
Posts: 142
Thanked 17 Times in 8 Posts
'96 Camry Stall and Hissing Problem

hey revscene, got a 96 camry 2.2L automatic with 110xxx km's on it. this is not my car but it stalled 4 times within the 2 days. it would come to a red light and stall. theres a lack of power and a hissing sound. the faster u drive, the louder the hiss is. what i plan to do is replace the distributor cap and rotor, wires, and plugs to start. if this helps, the CEL light is on for the pass 8 months (P0401) regarding the egr insufficient flow. also has a rattling catalytic converter which seems to have gotten worse. i thinking its the MAP sensor or TPS sensor. what do u guys think? i did some searching and got things like MAP. TPS, Distributor, even the torque converter. mixed answers but what your opinion? any help is greatly appreciated !

TIA
Advertisement
hondak20 is offline   Reply With Quote
Old 04-05-2012, 03:47 AM   #2
2x Variable Nockenwellen Steuerung
 
Join Date: Oct 2002
Location: N49.2 W122.1
Posts: 6,176
Thanked 1,174 Times in 704 Posts
it sounds more likely some pipe is leaking more than sensors.
godwin is offline   Reply With Quote
This post thanked by:
Old 04-05-2012, 05:31 AM   #3
Where's my RS Christmas Lobster?!
 
Prolowtone's Avatar
 
Join Date: Jan 2011
Location: Langley BC
Posts: 865
Thanked 336 Times in 109 Posts
no power, stalling and the hiss gets louder as you go faster... Massive vac leak (Check the little black hoses) *Just noticed other info.. so its reinforced by the EGR code
Prolowtone is offline   Reply With Quote
This post thanked by:
Old 04-05-2012, 10:30 AM   #4
Proud to be called a RS Regular!
 
hondak20's Avatar
 
Join Date: Feb 2011
Location: Vancouver
Posts: 142
Thanked 17 Times in 8 Posts
damn, ill look into it and see whats happening. he said in the morning, its ok, but like 3-5 mins after, itd start stalling and losing power. thanks guys, ganna go take a look
hondak20 is offline   Reply With Quote
Old 04-05-2012, 01:00 PM   #5
I Will not Admit my Addiction to RS
 
narfy's Avatar
 
Join Date: Dec 2002
Location: vancouver
Posts: 572
Thanked 57 Times in 45 Posts
find your vacuum leak first... sometimes, i take a can of brake clean, and while the engine is idling, shoot a bit of it near where i think it may be leaking from and listen for an RPM change... just be careful not to get this near your spark plug wires or distributor...

my guess is one of the vacuum hoses from the EGR vacuum switching valve to your EGR vacuum modulator is damaged or disconnected, causing your EGR valve to not open up. usually a fairly simple fix...
__________________
__________________
VZN185 - 32" BFG AT, 32" TOYO MT, OME suspension, ARB bumper, Warn winch, 3sixty LED light bar, TRD trans cooler, TRD exhaust, AMT sliders, budbuilt skids...
ZWA10 - stock F-sport with LEDs...
fng@regencyauto.com
narfy is offline   Reply With Quote
This post thanked by:
Old 04-05-2012, 02:05 PM   #6
I contribute to threads in the offtopic forum
 
Join Date: Oct 2009
Location: richmond
Posts: 2,838
Thanked 1,490 Times in 570 Posts
Rattling cat. Hissing as you drive gets louder as you do so. No power and stalling. Start with a new cat you already know its fucked why avoid it. A plugged cat will lead to all the symptoms you describe and more.
__________________
Rise Auto Salon

11938 95a Ave Delta
I can be reached VIA text @ 778-232-1465

Oil change special $70 5 liters synthetic oil including OEM filter Fender rolling from $45 per fender
Car Audio:
Focal, Morel, Genesis, Clarion, Scosche, Escort, Compustar, GReddy, Blitz, Tomei, Motul, Endless, Defi, Cusco, Nismo + More


We specialize in:
Custom Car Audio
Race/4x4 Fabrication
Forced Induction
Engine Swaps
General Maintenance
Phil@rise is offline   Reply With Quote
This post thanked by:
Old 04-12-2012, 11:50 PM   #7
Proud to be called a RS Regular!
 
hondak20's Avatar
 
Join Date: Feb 2011
Location: Vancouver
Posts: 142
Thanked 17 Times in 8 Posts
Quote:
Originally Posted by Phil@rise View Post
Rattling cat. Hissing as you drive gets louder as you do so. No power and stalling. Start with a new cat you already know its fucked why avoid it. A plugged cat will lead to all the symptoms you describe and more.
thanks for the input Phil. turns out it was the cat. it was plugged and the flex pipe was teared a little. now theres a clicking noise....BUT it runs fine now
hondak20 is offline   Reply With Quote
Old 04-13-2012, 11:47 AM   #8
I contribute to threads in the offtopic forum
 
Join Date: Oct 2009
Location: richmond
Posts: 2,838
Thanked 1,490 Times in 570 Posts
My pleasure bud
__________________
Rise Auto Salon

11938 95a Ave Delta
I can be reached VIA text @ 778-232-1465

Oil change special $70 5 liters synthetic oil including OEM filter Fender rolling from $45 per fender
Car Audio:
Focal, Morel, Genesis, Clarion, Scosche, Escort, Compustar, GReddy, Blitz, Tomei, Motul, Endless, Defi, Cusco, Nismo + More


We specialize in:
Custom Car Audio
Race/4x4 Fabrication
Forced Induction
Engine Swaps
General Maintenance
Phil@rise is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 11:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
Revscene.net cannot be held accountable for the actions of its members nor does the opinions of the members represent that of Revscene.net